Actualizar FFmpeg en Ubuntu 18.04 y derivados

Actualizar FFmpeg en Ubuntu 18.04, Ubuntu 16.04 y derivados.

FFmpeg es la herramienta en línea de comandos más potente y útil en Linux, si hablamos de transcodificación de archivos multimedia. Sus funciones son muchas, convertir archivos multimedia entre varios formatos de video y audio, o cambiar el tamaño de los videos son las dos más destacadas.

Hace uso de bibliotecas de audio y video comunes, como libavcode, libavformat y libavutil; pero a pesar de ello y por razones desconocidas, Ubuntu 18.04, Limux Mint 19.X y todos sus derivados, no disfrutan de la serie FFmpeg 4.X que es la última versión.

Son miles y miles los usuarios que aún disfrutan, de las distribuciones linux Ubuntu 18.04, Ubuntu 16.04 y todos sus derivados. En este artículo vemos como actualizar nuestro FFmpeg, a la versión 4.3.

Actualizar FFmpeg en Ubuntu

Actualizar FFmpeg en Ubuntu

 

Actualizar FFmpeg en Ubuntu 18.04 y derivados

Antes de comenzar, verificamos la versión instalada.

ffmpeg –version

En nuestro caso tenemos instalada, la versión 3.4.8.

Version instalada de FFmpeg

Versión instalada de FFmpeg

 

El paquete FFmpeg viene incluido en el repositorio predeterminado de Ubuntu, como no lo quieren actualizar, debemos agregar un ppa alternativo.

sudo add-apt-repository ppa:jonathonf/ffmpeg-4

Actualizamos…

sudo apt update

Vemos el nuevo paquete listo para su actualización.

sudo apt list --upgradable

En el ejemplo, observamos que la versión 4.3.2 está lista para ser instalada.

Actualizar FFmpeg a la version 4.3

Actualizar FFmpeg a la versión 4.3

 

Actualizamos.

sudo apt full-upgrade

Se instalan librerías nuevas.

root@sololinux:~# apt full-upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Calculando la actualización... Hecho
Se instalarán los siguientes paquetes NUEVOS:
  libaom0 libaribb24-0 libavcodec-extra58 libavdevice58 libavfilter7 libavformat58 libavresample4 libavutil56 libcodec2-0.7
  libmysofa1 libpocketsphinx3 libpostproc55 librabbitmq4 libsphinxbase3 libsrt1-gnutls libswresample3 libswscale5 libvidstab1.1
  libx264-155 libx265-192 libzimg2 ocl-icd-libopencl1
Se actualizarán los siguientes paquetes:
  ffmpeg libavcodec-extra libchromaprint1 libmysofa0 libopenmpt0
5 actualizados, 22 nuevos se instalarán, 0 para eliminar y 0 no actualizados.
Se necesita descargar 14,1 MB de archivos.
Se utilizarán 49,3 MB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n]

Una vez concluya el proceso, verifica la nueva versión instalada en el sistema.

ffmpeg –version

La actualización es correcta.

sergio@sololinux:~$ ffmpeg –version
ffmpeg version 4.3.2-0york0~18.04 Copyright (c) 2000-2021 the FFmpeg developers
  built with gcc 7 (Ubuntu 7.5.0-3ubuntu1~18.04)

Ejecuta los siguientes comandos, para visualizar todos los codificadores y decodificadores disponibles en la nueva versión de FFmpeg.

ffmpeg -encoders

ffmpeg -decoders

 

PD: El mantenimiento extendido de Canonical, también conocido como ESM, ofrece soporte sobre Ubuntu 16.04 hasta el año 2024.

 

Canales de Telegram: Canal SoloLinux – Canal SoloWordpress

Espero que este artículo te sea de utilidad, puedes ayudarnos a mantener el servidor con una donación (paypal), o también colaborar con el simple gesto de compartir nuestros artículos en tu sitio web, blog, foro o redes sociales. Actualizar FFmpeg en Ubuntu 18.04 y derivados.

Chat de SoloLinux en Telegram

 

Agregar comentario

1 logo sololinux

Suscríbete a SoloLinux

Recibe todos los nuevos artículos es tu correo electrónico

You have Successfully Subscribed!

Ir al contenido